Avius mobile device requirements and non-supported mobile devices

The mobile device requirements for Avius are: 


Android devices: Ultracom Avius requires the Bluetooth Low Energy (BLE) support and at least the Android version 5.0 (Lollipop). 


Apple devices: Ultracom Avius requires the Bluetooth Low Energ (BLE) support and at least Apple iOS version 8.0.


We have noticed compatibility issues with the listed mobile devices and Ultracom Avius: 

  • Oukitel (all models)
  • Blackview (all models)
  • Asus Zenfone models
  • LG G7 ThinQ
  • Cat S31


Problems can appear as disconnects, slow connection and no connection at all.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.